WordPress 4.2 Notice: register_sidebar was called incorrectly.

Support Forums for LiveMesh Themes & Plugins Forums Invent Theme Support WordPress 4.2 Notice: register_sidebar was called incorrectly.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #13772
    Liistamoliistamo
    Member

    Hi,

    When I updated WP to 4.2 I got this notice:
    Notice: register_sidebar was called incorrectly. No id was set in the arguments array for the “” sidebar. Defaulting to “”. Manually set the id to “” to silence this notice and keep existing sidebar content. Please see Debugging in WordPress for more information. (This message was added in version 4.2.0.) in /wp-includes/functions.php on line 3560

    Do you have a update for the ID thing for the Invent theme?

    #13781
    VeenaVeena
    Moderator

    We will investigate this issue and we will provide a fix quite soon.

    #13782
    Liistamoliistamo
    Member

    Sounds good.

    #13860
    VeenaVeena
    Moderator

    Actually we have tested in our installation and everything works fine. Can you pls share a link to your site with temporary access details as a private reply here? We will take a look.

    #13862
    Liistamoliistamo
    Member
    This reply has been marked as private.
    #13891
    RaghavendraRaghavendra
    Moderator

    I do not have enough rights to check the installation. Will need admin rights. Meanwhile, the error occurs if id attribute is missing from register_sidebar() function. I checked the theme code and we are setting the id attribute. Can you pls disable all plugins once and see if the error goes away? The notice can get displayed even if one of the plugins loaded calls this function with wrong arguments.

    If you provide me the admin rights, I can do a check again if the above does not help resolve the issue. Thanks.

Viewing 6 posts - 1 through 6 (of 6 total)
  • The forum ‘Invent Theme Support’ is closed to new topics and replies.