Missing segment backgrounds in Chrome

Support Forums for LiveMesh Themes & Plugins Forums Squash Theme Support Missing segment backgrounds in Chrome

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #850
    Rusteerustee
    Member

    I have just installed Squash on my website at the following address:

    http://howardthomson.co.uk/dev/

    It’s a clean install of WordPress, with the Squash theme and the sample data imported. I’ve noticed a couple of things aren’t working however.

    1) The background for the “team-intro” and “client-testimonials” isn’t showing in Chrome.

    2) The two background images mentioned above are appearing in Firefox and Safari, but in Safari, the background is scrolling with the page.

    I notice that your demo site works fine however. Is there a problem with the way I have installed the theme?

    Thanks in advance,

    Howard

    #851
    Livemeshlivemesh
    Keymaster

    This is some weird issue which is cropping up in some installations of Chrome and Safari too. Depends on which OS you are in. Works fine in Firefox/Opera and even IE. There are multiple things we can do to make the backgrounds appear –

    If you do not need fixed backgrounds (where the backgrounds stick while the contents scroll) –

    Change the option in the shortcode. Just edit the page, locate the word fixed_background=true and change it to fixed_background=false.

    The backgrounds should appear immediately upon this change.

    If you need the fixed background ( my preference) –

    Required –
    Pls remove reference to animate.css in framework.php. This means edit the file {theme directory}/framework/framework.php and remove the following lines –

    wp_register_style('animate', MO_THEME_URL . '/css/animate.css', array(), false, 'screen');
    

    and

    wp_enqueue_style('animate');
    

    No need to worry – this file is currently not being used since we are yet to implement animations into the page elements for this theme. When we do implement, we will only need a subset of these animations defined in this css file. This file will be removed from the theme update coming next week.

    Next, after removing animate.css reference, pls avoid using Flex Slider and instead use Revolution Slider or the Nivo Slider. Under Theme Options->General Tab, you should be able to choose Nivo Slider or else follow instructions provided in the documentation pdf for enabling revolution slider. Flex slider in the top slider area in Home Page is the only one causing issues with fixed backgrounds. Flex sliders elsewhere (like the one in Macbook or the iMac) seem to work fine.

    Will continue to work on this issue to get to the root cause of it.

    #910
    Livemeshlivemesh
    Keymaster

    If you have issues with backgrounds, pls remove the following styling defined in style.css file in the theme directory and animate.css file in the {theme directory}/css directory. Pls search and remove the following style definition –

    -webkit-backface-visibility: hidden;
    

    Removing it is not going to cause issues. It will be removed in the next update.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.