Homepage anchor links

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #5504
    EcogreensEcogreens
    Member

    Hi,

    When I visit other page, and then click the menu item with homepage anchor, the page could not jump to homepage.
    The anchors work great when I am in the main page. But once I am in a separate page, they don/t work at all. No response to the menu items with anchors if I click the menu in a different page. If I click the menu item, nothing happens. but if I right-button “open in a new tab”, it kind of works. doesn/t go to the right anchor, but at least it loads the correct page.
    Also, tried to fix the main.js as you suggested before. The menu works fine then, but the contents of the site don/t work at all. They just appear blank except for header and footer. In all pages of the site.

    I have my anchors in the menu written as “http://mysite.com/#pricing”. If I change them to “http://www.mysite.com/#pricing”, they work ok from different pages, but when I am in the main page, they reload the page and then go to the anchor.

    So no solution there.

    #5513
    ErnestoErnesto
    Member

    Hi,

    Could you please provide us a link to your website, so we can take a look at the issue?

    #5519
    EcogreensEcogreens
    Member
    This reply has been marked as private.
    #5531
    ErnestoErnesto
    Member

    Hi,
    Go to Settings>General in your Dashboard and set your “WordPress Addres” and “Site Address” with “www.” and the same with the href=

    That should do trick.

    #5535
    EcogreensEcogreens
    Member

    I added the www. to the Settings->General, as soon as to the menu items, unfortunately the problem remains.

    #5569
    EcogreensEcogreens
    Member

    Any help, please!

    #5602
    NexusNexus
    Moderator

    Pls reply back with a login to your site. I couldn’t reproduce the issue in my machine and also as you can see this doesn’t happen in demo site as well. Thanks!

    #5607
    EcogreensEcogreens
    Member
    This reply has been marked as private.
    #5648
    RaghavendraRaghavendra
    Moderator

    Have fixed the issue. Pls check. Will have the change that I made in the main.js file in the next update.

    #5655
    EcogreensEcogreens
    Member

    Thank you very much!

Viewing 10 posts - 1 through 10 (of 10 total)
  • The topic ‘Homepage anchor links’ is closed to new replies.