/Blog Missing from Breadcrumb

Tagged: ,

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #1495
    Mjjdesignsmjjdesigns
    Member

    The word Blog is missing from the breadcrumbs on the homepage of the blog, how can I get that to show up?

    Is there a setting that I’m missing somewhere?

    #1501
    Livemeshlivemesh
    Keymaster

    The theme currently does not populate the breadcrumb for the home page. Breadcrumb on the home page is pretty redundant since you are already in the page the breadcrumb points. Here is how it will look if we enabled breadcrumb on home page –

    https://docs.google.com/file/d/0B9j6FQo4cSQFSzEtT0ZGakpCbHc/edit?usp=drivesdk

    If you want to give a try, pls make the required change in framework/functions/breadcrumbs.php file at line number 36 – pls remove the check for home page is_front_page() and breadcrumb will show up in the home page. Hope this makes sense. Let me know if you have other thoughts or ideas on having breadcrumb for home page.

    #1502
    Mjjdesignsmjjdesigns
    Member

    The problem is that the blog isn’t the homepage of the site, it’s domain.com/blog

    If it’s not the homepage, shouldn’t the breadcrumb be correct?

    #1503
    Livemeshlivemesh
    Keymaster

    I am a little confused now – are you saying the blog page is not showing the breadcrumb? It does show if you have enabled it. And no matter which page you set as home page, it never displays the breadcrumb since the breadcrumb will not have any link other than the one pointing to Home.

    A URL to the problem page will help. You can use ‘Set as private reply’ option below for sending me the URL. Thanks

    #1504
    Mjjdesignsmjjdesigns
    Member
    This reply has been marked as private.
    #1517
    Livemeshlivemesh
    Keymaster

    I tested my local setup a little and looks like you are using the setting “Posts Page” in the Reading tab. If you do not specify this(see below screenshot), you should see the word “Blog” in the breadcrumb –

    https://docs.google.com/file/d/0B9j6FQo4cSQFNHAwakRJVTVZUzA/edit?usp=drivesdk

    Not choosing the Posts Page seems to be the correct behavior when you have a static page specified as Front Page. You choose either one of them not both since if you do specify both, WordPress seems to be getting confused and treating the blog page too as home page (e.g., you will see the name Home suffixed to the page title displayed on the top – if you do not override it in the options). And it does not display the page title at all if you choose this option and applies h1 tag to the site title(logo link in the header) at the top instead of applying it to the blog page title.

    Also make sure that the blog that your site utilizes is actually a page with page template ‘Blog’ chosen from the page templates dropdown as shown below –

    https://docs.google.com/file/d/0B9j6FQo4cSQFS3hqWnhwZWE3TXc/edit?usp=drivesdk

    #1518
    Mjjdesignsmjjdesigns
    Member

    That seemed to do the trick. Thanks a million!

Viewing 7 posts - 1 through 7 (of 7 total)
  • The forum ‘Enigmatic Theme Support’ is closed to new topics and replies.