Ytp Video Showcase Start Time Not Saved

Support Forums for LiveMesh Themes & Plugins Forums Agile Theme Support Ytp Video Showcase Start Time Not Saved

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #9742
    Kintz_09kintz_09
    Member

    I’ve implemented a full screen video using Ytp Video Showcase. It will not save the requested start time. I save it to start at 10 seconds and when I test it starts at the beginning. Next time I go to check the settings it is back to 0.

    I tried 10, 10seconds, 10sec, and 0:10 but none of them will save.

    What is the proper format for this to save? Or is there a fix for this?

    Thanks

    #9750
    RaghavendraRaghavendra
    Moderator

    Are you using the Visual Composer options window or the Shortcode Builder one? Can you pls confirm so that I can check? You can also type the shortcode manually into a text block as explained in the documentation.

    #9759
    Kintz_09kintz_09
    Member

    I tried it using the Front End Visual Composer and the Backend Visual Composer.

    #9761
    Kintz_09kintz_09
    Member

    Upon checking the shortcode in the text editor, it is showing the ‘startat’ value as ’10’ as I wanted. In the visual editor is showing up as 0. When visiting the site, the video initially shows an image of the 10 second mark in the video and then jump to the beginning as soon as it starts playing. Is this how it is intended to work?

    #9770
    RaghavendraRaghavendra
    Moderator

    That’s really strange that the value shown in visual editor is different from the one in the text editor. Will update you on a fix for this soon. Thanks

    #9771
    RaghavendraRaghavendra
    Moderator

    Pls modify the line number 65 of framework/shortcodes/video-shortcodes.php file to

                         
    '; ?>

    Will have this fix in the next update. Thanks for bringing this to our notice.

#9852
Kintz_09kintz_09
Member
This reply has been marked as private.
#9871
RaghavendraRaghavendra
Moderator

Pls post a temp login and I will make the required change for you. I saw the site and looks like the copy paste from the post above messed up the HTML generated.

#9876
Kintz_09kintz_09
Member
This reply has been marked as private.
#9877
Kintz_09kintz_09
Member
This reply has been marked as private.
#9898
RaghavendraRaghavendra
Moderator

For some reason, the shortcode attribute was not being taken. Will need the FTP information to see why this is happening (risky to try editing too much PHP from frontend) but I modified the source to take a default startAt to be 10 and the video is being started from 10 seconds. When we set the startAt though, the video stops auto playing. I did specify the attribute autoplay to true as per the instructions in wiki –

https://github.com/pupunzi/jquery.mb.YTPlayer/wiki

but the video plays only when you click on the play button.

#9900
RaghavendraRaghavendra
Moderator

BTW, have you considered uploading the video which starts from the place you desire to start?

#9906
Kintz_09kintz_09
Member

We have already uploaded a new video which can start at the beginning so I do not need it to start at 10s anymore. Mostly I want the feature to be stable so I can hand off the pages to the non-technical folks. Thanks for the help. I will get you ftp credentials for the staging server sometime next week.

Thank you!

#9964
Kintz_09kintz_09
Member

I’ve discovered some more issues with this feature. After the changes you made, I was unable to get the video to autoplay at all, which is very important. So I took a fresh copy of the shortcode file and made the change you suggested above. Please note that the issue I experienced copy and pasting last time was from an extra space in the code above that I copied. The beginning <?php should not have the space in it. You may want to fix that in the above post so others don’t have the same issue.

So after making the edit, the video plays properly, however the play buttons are now in the upper right hand corner and are disabled. How can I fix this? Even when set to disabled the grayed out buttons appear in the upper left hand corner.

Some items are still not remembered properly when using the frontend or backend editor. This causes settings to be overridden on accident.

My video also gets cut off at the bottom, therefore our software interface cannot be seen. Is there a way to control this? I’d prefer to see the whole video resized accordingly to fit the display.

When using the visual editor, making any change causes the ‘hide header on page’ option to clear re-enabling the header. This is bad enough that it makes the VC editor unusable in my opinion.

#9997
RaghavendraRaghavendra
Moderator

Will have the issues with the visual composer fixed. I see that most attributes are getting saved except for couple of them.

For the video getting cut off, can you see if the following custom CSS helps –

@media only screen and (max-width: 1399px) {
.ytp-video-showcase .video-header {
max-height: 900px;
}
}

For now, since you do not need the startAt attribute, I reverted the code back to original one and buttons look fine now. Looks like the HTML was messed up due to the copy paste of source code that happened.

Will get back to you with the fix for couple of attributes which are not reflecting in the visual composer.

Viewing 15 posts - 1 through 15 (of 15 total)
  • The forum ‘Agile Theme Support’ is closed to new topics and replies.