Problem with VC created Page Sections when used for Pages.

Support Forums for LiveMesh Themes & Plugins Forums Agile Theme Support Problem with VC created Page Sections when used for Pages.

This topic is: resolved

This topic contains 2 replies, has 2 voices, and was last updated by Kitemaniac Kitemaniac 4 years, 10 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #12047
    Kitemaniac
    Kitemaniac
    Member
    Post count: 5

    Hi

    My website shall be designed as multiple single pages (5 main “menu” pages, each as a single-page). Since I am not adept in raw coding I assemble each page with page sections which I mainly create with the Visual Composer.

    Now, when I finish creating a page section and update it, the preview shows exactly the formatting/design of the elements I have chosen and added with the VC (e.g. Tabs, pictures, header fancy etc..).
    However, as soon as I want to add said page section to a main page, all formatting is lost, everything is aligned left and some of the VC elements (e.g. “separator with text”) is just shown as plain text.

    Can you please tell what I have to do so that the page sections I composed with the VC maintain their form when I use them as a page element? Do I have to use a special element (e.g. “wrap”) to fix the formatting of the page section’s content?

    Thank you so much in advance!

    • This topic was modified 4 years, 10 months ago by Kitemaniac Kitemaniac.
    #12066
    Raghavendra
    Raghavendra
    Moderator
    Post count: 4684

    The visual composer optimizes loading of visual composer stylesheets by checking the page for any visual composer content. This does not help our case since a page built with page sections does not have content of its own. To force visual composer to load the required styles, pls enter some content with visual composer shortcode like a simple one line

    [vc_row]
    

    to the content of the page with template “Single Page Site” and the page should render fine. The theme itself tries not to use visual composer with Single Page Site template but the above suggestion should work. It uses Full Width template for visual composer built home pages as seen in the demo data.

    #12071
    Kitemaniac
    Kitemaniac
    Member
    Post count: 5

    Wow, thank you so much meteorite, now it works just as it should.
    Great theme and customer service!

    Thank you again,
    Jason

Viewing 3 posts - 1 through 3 (of 3 total)

The topic ‘Problem with VC created Page Sections when used for Pages.’ is closed to new replies.