Translations

Viewing 15 posts - 1 through 15 (of 30 total)
  • Author
    Posts
  • #31289
    Jeroen RottyJeroen Rotty
    Participant

    Hi there,
    Client of mine which purchased the theme himself has issues translating things. Not everything the theme uses is translatable or is in the .po/.mo files.

    Please add:
    – Certifications
    – Specializations
    – Get in touch
    – Hover icons/text
    – Facts about
    – Read more on the blog posts/articles
    – View details (sportcarousel photos)

    Probably more, I’ll ask him to reply here or get to me to list them all.

    Please make this happen in a theme update.

    Thanks,
    Jeroen

    #31294
    VeenaVeena
    Moderator
    This reply has been marked as private.
    #31309
    Jeroen RottyJeroen Rotty
    Participant

    Hi,

    I see it all in the en_US files, but when i open them in PoEdit and translate them, change the settings to nl_NL and then upload them in wp-content/languages/themes/fitpro-nl_NL.po and .mo they don’t work, which should.

    Also tried in the childtheme folder/languages/nl_NL.po & .mo but they don’t pick up there as well.

    Are you sure the theme is using it’s i18n functions right?
    load_theme_textdomain in framework.php referes to a locale.php file. But shouldn’t that be a .mo file?

    Please check this, as I still can’t make it show up.

    Jeroen

    #31310
    Jeroen RottyJeroen Rotty
    Participant

    I saw something in your readme about /option-tree/languages/theme-mode/nl_NL.mo and .po but that doesn’t work as well…

    #31316
    VeenaVeena
    Moderator

    nl_NL.po & .mo should work. Not sure what is happening. Did you update the file initially?
    Could you pls share the files here ? Will check .

    #31318
    Jeroen RottyJeroen Rotty
    Participant
    This reply has been marked as private.
    #31320
    VeenaVeena
    Moderator

    You just need to add it in theme’s languages folder. Update the file and make required changes then hit save button.

    #31321
    Jeroen RottyJeroen Rotty
    Participant

    Well that doesn’t add any value to this conversation as I already mentioned I tried that, no luck! Using a childtheme – tried in both parent and childtheme /languages folder as nl_NL.po and nl_NL.mo – did that work for you then? (with my files?)

    #31322
    Jeroen RottyJeroen Rotty
    Participant
    This reply has been marked as private.
    #31325
    VeenaVeena
    Moderator

    Ok. Will get back to you shortly .

    #31326
    VeenaVeena
    Moderator

    Wordpress login info is not working it seems. Can you pls check?

    #31327
    VeenaVeena
    Moderator

    BTW did you change the language in settings > General screen?

    #31328
    Jeroen RottyJeroen Rotty
    Participant
    This reply has been marked as private.
    #31332
    VeenaVeena
    Moderator
    This reply has been marked as private.
    #31344
    Jeroen RottyJeroen Rotty
    Participant

    Hi,

    Any news yet?

    Jeroen

Viewing 15 posts - 1 through 15 (of 30 total)
  • You must be logged in to reply to this topic.