Summary length blog post

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #6045
    Djgritzdjgritz
    Member

    Hi. I’d like to expand the text length of my blog posts on the BLOG page to include all text so for the post. How do I change this? I saw something on these boards where suggested putting code in line 4xx and 5xx of post-functions.php, but my post-functions.php ends at line 322.

    #6052
    ErnestoErnesto
    Member

    Hi! Yes, the question must be from another theme. Depending on which shortcode you´re using to create the blog page the line will be different, for example, when using Popular Posts it´ll be line 35. However, you can se this for yourself, the line you´ll need to modify will look like this:

    'excerpt_count' => '50'

    And you´ll need to change it to the number of characters you want the post to display.

    #6053
    Djgritzdjgritz
    Member

    Hi. I’m using the EXTINCT theme. There is not a line of code in the Extinct post-functions.php that contains ‘excerpt_count’ etc. Where can I find this in the Extinct theme files?

    #6055
    ErnestoErnesto
    Member

    Hi, you´ll need to go to framework/shortcodes/post-shortcodes.

    #6057
    Djgritzdjgritz
    Member

    Ok, thank you. Although I am bit confused now … do I need to put short codes in my blog posts?

    #6059
    Djgritzdjgritz
    Member

    I just changed every line in in the post-shortcodes.php with an ‘excerpt-count’ line to no effect.

    #6060
    Djgritzdjgritz
    Member

    my blog page URL: http://gritzphoto.com/blog/

    #6081
    ErnestoErnesto
    Member

    Hi, you´ll need to go to the post-functions file and in line #300, you´ll need to replace this code:
    $output .= $excerpt_text

    With the following line:
    $output .= get_the_content()

    Let me now if that works out!

    #6094
    RaghavendraRaghavendra
    Moderator

    You can try to enable the option “Show Content in Archive Pages” in the Blog tab of theme options and see if that helps. If you have some more tags inserted into the content, you will need to remove them (sample data has these more tags inserted into the blog posts).

    #6255
    Djgritzdjgritz
    Member

    Unfortunately, neither of these above methods worked. Changed the excerpt length in the theme options works up to a certain amount of characters. So there is something else in the code restricting the amount of characters for the blog posts on the blog page. Is the creator of this theme available to answer this?

    #6305
    ErnestoErnesto
    Member

    Hi,

    The setting change in the theme options panel should work fine. Anyway, you can try to open the file “framework/functions/blog-content.php”. In line #203, replace this code:

    $show_content = mo_get_theme_option('mo_show_content_in_archives');

    With:

    $show_content = true;

    Try that and let us know the results.

    #6565
    Djgritzdjgritz
    Member

    Replacing the blog-content.php line was the ticket! Thanks.

Viewing 12 posts - 1 through 12 (of 12 total)
  • The topic ‘Summary length blog post’ is closed to new replies.