Staff specialism view 'next page' link broken

Support Forums for LiveMesh Themes & Plugins Forums Invent Theme Support Staff specialism view 'next page' link broken

Tagged: ,

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #14769
    Ben_TTMBen_TTM
    Member

    On my staff page, the ‘page 2’ etc links at the bottom of each specialism page are broken. See link below – if you click on Support Staff, then scroll down and click page ‘2’ it doesn’t work.

    http://beta.richmond.doncaster.sch.uk/staff/

    There’s no option to set this as a private message so I can’t give you Admin access unless you have an email address I can use.

    #14775
    RaghavendraRaghavendra
    Moderator

    We are able to reproduce this on our test site. Looks like the custom taxonomy pages (with page number > 1) are pointing to search page instead of taxonomy pages. Will get back to you with a fix within next few hours. Thanks

    #14822
    RaghavendraRaghavendra
    Moderator

    Have fixed the same in your site by editing the file loop-staff.php. Just moved the wp_reset_query function call to line number 149 of this file below the endif. Will have the update ready for submission on Monday which will have this fix in place.

    Thanks for helping us find this one.

    #14827
    Ben_TTMBen_TTM
    Member

    Thanks for looking into this. There seems to be a couple of issues still.

    The page buttons have stopped displaying on the ‘All’ staff view though – it must have been to do with the updates we’ve made. http://beta.richmond.doncaster.sch.uk/staff/

    Also, I changed the image size on the loop-staff.php to ‘full’ and the ‘posts per page’ to 12. All seemed to work fine but, when you go to a staff specialization page and click on page 2, you can see that the post snippets come to an end but there’s still a ‘page 3’ link and it just leads to an empty page. http://beta.richmond.doncaster.sch.uk/specialization/teaching-staff/page/2/

    #14830
    RaghavendraRaghavendra
    Moderator

    The All staff seems to be doing fine. I see no issues – is this resolved?

    Regarding setting post count to 12, you will need to set the same number or higher in Settings->Permalinks (Blog Posts show atmost). The pagination links should display fine then.

    #14831
    RaghavendraRaghavendra
    Moderator

    Sorry, that should be Settings->Reading screen where you set the number of posts to display.

    #14832
    Ben_TTMBen_TTM
    Member

    Almost there. It’s just the pagination links still missing from the ‘All’ staff view http://beta.richmond.doncaster.sch.uk/staff/ There are 40 staff profiles but the ‘All’ staff page is only showing 12 snippets and no links at the bottom – see attached. I’m on the latest Chrome

    Attachments:
    #14872
    RaghavendraRaghavendra
    Moderator

    Should be fixed. Have made the change in framework/extensions/framework-extender.php and in loop-staff.php. Pls check if things look ok now.

    Will have to incorporate the change into the update.

    #14874
    Ben_TTMBen_TTM
    Member

    Fantastic, all good now. I’ll give you guys a 5 star rating on Themeforest sometime when I get a minute. Thanks for your help, it’s a great template

    #14888
    RaghavendraRaghavendra
    Moderator

    Thanks for the feedback. Appreciate you taking the time to rate us.

Viewing 10 posts - 1 through 10 (of 10 total)
  • The topic ‘Staff specialism view 'next page' link broken’ is closed to new replies.