Setting language doesn't work

Tagged: 

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #11102
    Yanivnyanivn
    Member

    Hey,

    First I would like to thank you for this great theme!

    I purchased today the theme that also includes the languages folder with several examples.
    Now, I was trying to change the language per to your guideline, but it fails

    Then open the wp-config.php file from the root folder of your WordPress install, and replace the line:

    For example:
    define ('WPLANG', 'de_DE');

    The languages folder is in the following path:
    C:\wamp\www\agile-wp\wp-content\themes\agile\languages
    And it includes the de_DE.mo and de_DE.po as originally provided by you.

    I started to debug the software, but again, nothing helps..
    I am a programmer, but with medium experience in wordpress.

    The wordpress version I am using is of version 4
    I only care to change the theme frontend language and not the admin that is english.

    #11104
    Yanivnyanivn
    Member

    Actually, I just found that the change I did above changes the backend language, but doesn’t change the front end language.
    Is that point? can it changes only the backend?

    #11112
    VeenaVeena
    Moderator

    It will also affect the frontend.
    You have to do an update(hit update button on the top) in POEdit to see all the strings.

    #11124
    Yanivnyanivn
    Member

    WOW – amazing!!!

    Do you have a TIP how to translate the rest of the site? e.g. posts, portfolio and pages:
    1. Titles
    2. Content

    Many thanks!
    Yaniv

    #11142
    VeenaVeena
    Moderator

    Sorry Yaniv, I am not an expert in this area to give any tip. Pls google it.

    #11146
    Yanivnyanivn
    Member

    Thanks you.
    I will.
    Yaniv

Viewing 6 posts - 1 through 6 (of 6 total)
  • The topic ‘Setting language doesn't work’ is closed to new replies.