Remove the mouseover effect on Portfolio Thumbnails

Support Forums for LiveMesh Themes & Plugins Forums Squash Theme Support Remove the mouseover effect on Portfolio Thumbnails

This topic is: resolved

This topic contains 3 replies, has 2 voices, and was last updated by Overtimenyc overtimenyc 6 years, 1 month ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1109
    Overtimenyc
    overtimenyc
    Member
    Post count: 3

    On http://itoplist.com/ when you however over the thumbnail images from the portfolio, you get a blue effect. How can I remove that?

    Also what do I do to make the thumb image simply open up a lightbox? (without the user needing to hit on the zoomin icon)

    #1117
    Livemesh
    livemesh
    Keymaster
    Post count: 1011

    To make the image open up the lightbox image, you need to make the following change in thumbnail-functions.php file located in framework/functions/ folder.

    Change line number number 28 to

    function mo_show_image_info($context) {
    
        return ($context == 'archive' || $context == 'starter');
    
    }
    

    and then line number 99 in the same file from –

    if (empty($before_html)) {
                $before_html = '';
                $after_html = '' . $after_html;
            }
    

    to –

    $rel_attribute = 'rel="prettyPhoto[' . $context . ']" ';
    
            if (empty($before_html)) {
                $before_html = '';
                $after_html = '' . $after_html;
            }
    

    This will get rid of the hover effect and will make the whole image a link.

    #1120
    Livemesh
    livemesh
    Keymaster
    Post count: 1011

    BTW, I personally feel you need to do this (input CSS into Custom CSS tab in options panel) for better usability ( I think that was your original idea too originally as posted in an earlier question) –

    .type-portfolio .image-area .image-info h3 { display: none; }
    

    This will help you avoid having to make the above code changes. And you can get rid of the hover color by doing this –

    .type-portfolio .image-area .image-info { background: none; }
    
    #1122
    Overtimenyc
    overtimenyc
    Member
    Post count: 3

    Thank you so much Livemesh! I do agree that modifying the CSS is the better approach for the reasons you have mentioned. I have went and made the change you have suggested via Custom CSS tab and it works perfectly!

    Thank you again for your support!

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.