Please Help in Improving Page Speed

Support Forums for LiveMesh Themes & Plugins Forums Enigmatic Theme Support Please Help in Improving Page Speed

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #8275


    We are a building a corporate website ( using paid version of your Enigmatic theme. We are in the verge of making it live soon, but found a major issue in terms of Page speed time. It is really high at the moment.

    As per Google Page Speed Analysis the scores are – 63/ 100 (for Desktop), and 53/100 (for Mobile) version. We also tried measuring it using Pingdom.

    I am attaching a document for the score report and the recommendation details from Google for further reference. Please our site in dev platform and suggest how to compress images, CSS and avoid latency.

    Please help us fixing this overall page speed issue with your expert ideas and we should implement the same.

    I will wait for your reply.



    Try to do these (if you have not done so already) and see if things improve –

    1) Install caching plugin. I recommend WP-Super-Cache. Will avoid database hits and thumbnail generation.

    2) Try using WP-minify plugin to combine JS, CSS files into a single file.

    3) Try to enable compression in WP-Super-Cache.

    Pls give a try and your score should improve.



    I just added the wp minify plug in. WP Super Cache was already there. My site URL:

    However, now the Revolution slider has stopped working and an error message displays like this:

    Revolution Slider Error: You have some jquery.js library include that comes after the revolution files js include.
    This includes make eliminates the revolution slider libraries, and make it not work.

    To fix it you can:
    1. In the Slider Settings -> Troubleshooting set option: Put JS Includes To Body option to true.
    2. Find the double jquery.js include and remove it.

    I could do the Option 1, but did not find the double jquery.js include, so could not remove it. Now I have deactivated the both WP Minify and WP Super Cache plug in.

    Please help me soon.


    Can you try just doing minify/combine for CSS only and see if that makes a difference. Minifying JS is probably the cause of this error.


    I see two includes which seems to be cause of the error. It is not jquery.js which is included twice but a jquery lib (the rev slider js in this case) which is included twice and which is the cause of the error.

    “You have some jquery.js library include that comes after the revolution files js include”

Viewing 5 posts - 1 through 5 (of 5 total)
  • The forum ‘Enigmatic Theme Support’ is closed to new topics and replies.