Parallax effect is not working

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #5640
    Onlineadguyonlineadguy
    Member

    Hi i have followed your docs & video for installing & adding contents to our site But one page parallax effect is not working at all. When i am trying to click on the menu bar to go next content section it is loading the whole site & taking me to another page. You can have a look at my link
    http://sitepreview.lasvegaswebsolutions.com/vp/

    #5688
    RaghavendraRaghavendra
    Moderator
    This reply has been marked as private.
    #5690
    RaghavendraRaghavendra
    Moderator
    This reply has been marked as private.
    #5710
    Daruetschdaruetsch
    Member

    I have the sam problem… any help?

    #5715
    Daruetschdaruetsch
    Member

    You can have a look at my link: http://freestyle-uri.ch/

    #5724
    NexusNexus
    Moderator

    You will have to give the links like this http://freestyle-uri.ch/#contact . Thanks!

    #8960
    Daruetschdaruetsch
    Member

    thanks for that answer,
    now when i wher on a subpage thaht link (http://freestyle-uri.ch/#contact)does not work 🙁 any help?

    #8985
    RaghavendraRaghavendra
    Moderator

    Looks like the website is in maintenance or coming soon mode. Is there a way you can post a temp login to the site so that I can take a look? You will have to open a separate thread to avoid the user who opened the thread from seeing the login. Pls do open a thread and give us the login by replying as a private message. Thanks

    #10414

    Hi there. First off, love the theme and am having a lot of fun with it. I have this same question about parallax menus. I’ve figured out on my homepage to simply add the “#” in order to get the scrolling effect. However, my problem is when I go to sub-pages the menu no longer works.

    For an example visit http://www.snapintegration.com/

    – Click on “services” and it scrolls down as expected. However, then click on “consultation” which takes you to a sub page. Once on the “consultation” page you’ll notice that the header menu no longer works and the only way back to the home page is to click on the “snap integration” logo at the top left.

    Any suggestions?

    #10421
    VeenaVeena
    Moderator

    Hi jasongriffing,

    We have released an update which has this fix.Kindly check it.

    Thanks

    #10437

    Thank you. I’m sorry for the silly question, but do you have documentation explaining how to update? In the past with themes I’ve used I’m able to just update through the wordpress backend themes manager. However, that doesn’t appear to be the case with this theme.

    Do I simply re-download the files from themeforest? And if so, what exact files should I upload to wordpress?

    Lastly – is there anything I need to do to prevent changes and modifications from being lost when I update?

    Thanks so much for getting back to me.
    Best,
    JG

    #10449
    RaghavendraRaghavendra
    Moderator

    The way I update is to replace all files. No matter what method you use (there are plugins too like this – http://wordpress.org/plugins/easy-theme-and-plugin-upgrades/ to update easily), you will need to backup your changes and redo any changes you made to the files on the new installation.

    Use tools like DiffMerge or WinMerge to compare the old and new files and redo the changes. You will spend probably an hour doing this but not more, specially if you have made changes only to a few select files. The settings data will stay and hence Custom CSS entered into theme options should be fine. It’s always a good idea to have a backup though. Hope this helps.

    Best way to protect yourself from theme updates is to always make changes in the child theme. The theme is mostly child theme friendly and hence when you have time, you can probably go through the changes you have made to the core theme files and try to move them to child theme so that the core files are not affected and upgrades are smoother.

    #10466

    Meteroite – Thank you so much for your continual quick responses. Really appreciate it. I got my theme updated to 3.1 with no issues and am now running a child theme of that one to protect me on future updates. All good there.

    It certainly made a difference in that my primary menu links now work from secondary pages. However, it’s still exhibiting some strange behavior. This might be a better topic for a separate thread but I’m going to post it here and you can tell me.

    If you follow the same steps as above:
    – Go to snapeintegration.com
    – Click on services – parallax effect works exactly as expected
    – Next click on learn more under ‘consultation
    – From the consultation page click on ‘services’ again in the primary menu

    Now notice the placement of where the page loads. The heading ‘services’ is half way cut off when this loads from a secondary page, even though the placement works fine when you click on it from the same menu on the main page.

    Any suggestions?

    Thanks again,
    JG

    #10493
    RaghavendraRaghavendra
    Moderator

    I did take a look at the “issue”. It is not an issue as such and normal behavior of the browser to push the focus exactly to the right spot. The reason you are seeing the services being cut off is due to presence of sticky menu which is position: fixed and hence makes that go out of flow. For the home page, we interrupt the click via Smooth Scroll JavaScript, which has an offset of some -50 pixels so that it actually pushes the focus by about 50 pixels so that the problem of sticky menu overlapping does not come into picture. For external navigation, we do not have a way to interrupt the user navigation since it happens from another window and the click event context is not available when the linked page is opened from the external page.

    I know this is all technical but hope you get the idea. If you do type the link from the address bar, you will land in the same spot as you would when navigating from the external page.

Viewing 14 posts - 1 through 14 (of 14 total)
  • The forum ‘Agile Theme Support’ is closed to new topics and replies.