Menu anchors don't work in Safari

Support Forums for LiveMesh Themes & Plugins Forums Fusion Theme Support Menu anchors don't work in Safari

Tagged: , ,

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #16519
    Gerhardagerharda
    Participant

    Dear Livemesh Team,

    I have an issue that others have brought up before, but I cannot seem to find any conclusive answers in related topics. I also remember this issue from Agile, and I remember solving it a year ago. I tried the same strategies in Fusion, but it won’t work. This issue relates to the Safari browser.

    In Safari, both on the Mac and the iPhone, the menu anchors won’t work. I set the menu items up as custom links like this:
    http://www.arensbak.com/#welcome

    In my Agile installation, Safari accepts such custom anchor links and confirms the menu item target in the status bar: Go to “#anchor” on this page.

    In my Fusion installation, it treats custom anchor links differently and states in the status bar: Go to “http://arensbak.com/#welcome”. (It does the same thing in your live showcase at https://www.livemeshthemes.com/themes/?theme=Fusion – but there the menu works properly in Safari.)

    This issue does not occur in Firefox and MSIE.

    Hint: At the same time, Smooth Scroll doesn’t work on my site in any browser – but this may be a different issue for a different topic.

    Please help.

    Kind regards,
    Gerhard

    #16524
    VeenaVeena
    Moderator

    Pls share a temp login to your site as a private reply here.

    #16527
    Gerhardagerharda
    Participant
    This reply has been marked as private.
    #16532
    VeenaVeena
    Moderator
    This reply has been marked as private.
    #16536
    Gerhardagerharda
    Participant

    Hey Phoenix,

    Thanks a bunch, works like a charm in all browsers now. I’ll adjust the custom links in the other menus myself now.

    The funny thing is though, it was exactly the other way round in the Agile theme, where the www had to be added to make it work.

    I have a few issues more (image placing/grid, image sizes), and I’ll open a new topic in case I need more help.

    Many thanks and greetings from Germany!

    Best,
    Gerhard

Viewing 5 posts - 1 through 5 (of 5 total)
  • The topic ‘Menu anchors don't work in Safari’ is closed to new replies.