Maintaining natural height of images in the blog post

Support Forums for LiveMesh Themes & Plugins Forums Enticing Theme Support Maintaining natural height of images in the blog post

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #119
    Anonymousanonymous
    Member

    I am still trying to find the place to change the images sizes so they would display on the single post pages with the width you are using but with the image proportionally sized with an open height but I am not sure what to change. I remember reading something about setting the height with timthumb to 9999 but it didn’t work right

    #121
    Livemeshlivemesh
    Keymaster

    Here is the solution you requested –

    Modify the utilit-functions.php file in the {wp-installation}\wp-content\themes\enticing\framework\functions directory. FYI – the only change I made was to change the line towards the end of the utility-functions.php file –

    $args['image_size'] = 'list-thumb';
    to
    $args['image_size'] = array(width => 628, height => 0);

    Keeping height 0 helps timthumb auto calculate the height based actual image size.

    Then, prevent css from styling it to old image size by pasting the below in Custom CSS tab of options panel or into custom.css file in /custom folder.

    .image-container.full .thumbnail {
    width: 628px;
    height: auto;
    }

    Hope this helps. Let us know if you still see issues. Email me in case you need the modified php file with the change in it.

    #439
    Atutahinikolasa
    Guest

    Hiya – this has totally helped, but I’m wanting to reduce the site to 300px instead of 628px, I’ve done that but need padding around the outside of the frame on the right, any suggestions?

    Can’t wait till we launch, I’ll send you the link, the site is gorgeous!!

    #488
    Atutahiatutahi
    Member

    here is the site: http://www.tearawawhanauora.org.nz – still working on the issue with images in blog posts..

    how do I remove the image completely?

    #496
    Livemeshlivemesh
    Keymaster

    The site looks gorgeous no doubt. Sorry I could not help you on time with the images and looks like you have solved it yourself.

    Also, pls have a look at the site on mobile/phone. Looks great but the custom menu is a little messed up. Pls check.

    You may want to hide the mega uber menu and simply use the responsive menu provided by the theme. Pls insert the following css into Custom CSS tab in Enticing options panel and see if that helps –

    @media only screen and (max-width: 767px) {
    
    #primary-menu {
    display: none;
    }
    
    }
    

    Hope this helps.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.