Livemesh Grid PRO version doesn't display shortcodes in excerpts

Support Forums for LiveMesh Themes & Plugins Forums Elementor Addons Support Livemesh Grid PRO version doesn't display shortcodes in excerpts

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #29114
    Fatie TokoFatie Toko
    Participant

    Hello,

    I am creating a site which displays books reviews : https://ere-digitale-en-resumes.com/ (GeneratePress Premium + Elementor)

    I’m using the Reviewer plugin to assign ratings to each book. I need to add the rating stars at the end of excerpts on archive pages and post grids. The Reviewer plugin provides a shortcode for that. So I have hooked “wp_trim_excerpt” in order to automatically append the review shortcode to excerpts.

    This works very well on GeneratePress archive pages, Elementor post grids, and Livemesh post grid FREE version, as shown here : https://ere-digitale-en-resumes.com/tous-les-livres/

    I purchased and installed the Elementor Addons PRO version because I need the pagination : rating stars don’t show any more. I have tried to manually enter the shortcode at the end of the excerpt, same result.

    Do you have any solution to execute a shortcode in post grid excerpts PRO version ?

    Thanks,

    Bérangère

    #29122
    RaghavendraRaghavendra
    Moderator

    Fatie – I will have a look at the issue and get back to you within next few hours. Thanks for bringing this to our attention.

    #29132
    RaghavendraRaghavendra
    Moderator

    We have released a new version which has the fix. Pls have a look and get back to us in case you have any issues. Thanks again.

    #29149
    Fatie TokoFatie Toko
    Participant

    Hello,

    Thanks for your reactivity !

    I have implemented the new release. Now HTML tags and shortcodes are usable in excerpts.

    Unfortunately this doesn’t solve my issue. The shortcode from the Reviewer plugin is executed but displays an error message because it cannot identify the post_id. Other thing, the shortcode must be appended manually for each post. My hook on “wp_trim_excerpt” to append it automatically doesn’t work.

    I don’t wish to spend too much time on plugin compatibility issues, so I will use a standard archive with a category widget.

    So consider this as resolved, at least my issue has helped to improve the product.

    Cheers
    Bérangère

    #29154
    RaghavendraRaghavendra
    Moderator

    Sure will keep an eye on that for next update. Thanks for your detailed feedback.

Viewing 5 posts - 1 through 5 (of 5 total)
  • The forum ‘Elementor Addons Support’ is closed to new topics and replies.