jQuery Visual UI Editor Break

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #21451
    Zludlowzludlow
    Member

    Most of the content of my site using the Squash theme is presently not able to be updated due to the following error with the theme: see attached image

    Look at the following urls and search for “template.get” to see others who are having similar problems and have been offered support by the theme developer. My suspicion is that one of the base components that the theme relies on, jQuery UI, has been updated and has a change that breaks the visual UI editor of the theme.

    http://themeforest.net/item/porto-responsive-wordpress-woocommerce-theme/9207399/comments?page=125

    http://themeforest.net/item/bakery-wordpress-bakery-cakery-food-theme/11112118/comments?page=33

    The following is the text of the error in the screenshot attached:
    backend.min.js?ver=4.10:6 Uncaught TypeError: $template.get is not a functionvc.shortcode_view.Backbone.View.extend.html2element @ backend.min.js?ver=4.10:6vc.shortcode_view.Backbone.View.extend.render @ backend.min.js?ver=4.10:6vc.visualComposerView.Backbone.View.extend.appendShortcode @ backend.min.js?ver=4.10:6(anonymous function) @ backend.min.js?ver=4.10:6(anonymous function) @ load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,jquery-ui-mo…:71m.each.m.forEach @ load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,jquery-ui-mo…:71vc.visualComposerView.Backbone.View.extend.addChild @ backend.min.js?ver=4.10:6vc.visualComposerView.Backbone.View.extend.addAll @ backend.min.js?ver=4.10:6_ @ load-scripts.php?c=0&load[]=jquery-ui-resizable,jquery-ui-button,jquery-ui-position,jquery-ui-dialo…:78m @ load-scripts.php?c=0&load[]=jquery-ui-resizable,jquery-ui-button,jquery-ui-position,jquery-ui-dialo…:78f @ load-scripts.php?c=0&load[]=jquery-ui-resizable,jquery-ui-button,jquery-ui-position,jquery-ui-dialo…:78l.trigger @ load-scripts.php?c=0&load[]=jquery-ui-resizable,jquery-ui-button,jquery-ui-position,jquery-ui-dialo…:78i.extend.reset @ load-scripts.php?c=0&load[]=jquery-ui-resizable,jquery-ui-button,jquery-ui-position,jquery-ui-dialo…:78t.success @ load-scripts.php?c=0&load[]=jquery-ui-resizable,jquery-ui-button,jquery-ui-position,jquery-ui-dialo…:78vc.shortcodes_collection.Backbone.Collection.extend.sync @ backend.min.js?ver=4.10:6i.extend.fetch @ load-scripts.php?c=0&load[]=jquery-ui-resizable,jquery-ui-button,jquery-ui-position,jquery-ui-dialo…:78(anonymous function) @ backend.min.js?ver=4.10:7(anonymous function) @ load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,jquery-ui-mo…:71

    Attachments:
    #21475
    RaghavendraRaghavendra
    Moderator

    Can I get a temp login to the site? I do not see why the Visual Editor would break since we are not customizing it in any way in our theme.

    #21536
    Zludlowzludlow
    Member
    This reply has been marked as private.
    #21576
    RaghavendraRaghavendra
    Moderator

    You just need to update the Visual Composer and the error should go away. Can you pls upgrade your VC to the latest version 4.11.2? The current version 4.10 certainly does not work with WordPress 4.5 version.

    #21577
    Zludlowzludlow
    Member

    Thank you for your reply.

    Updated it now and the issue still remains. Were you able to look in to my initial problem?

    This page starts to load, but doesn't finish.

    image-1

    Attachments:
    #21583
    RaghavendraRaghavendra
    Moderator

    Still the old VC 4.10 is activated. I do not see the VC updated.

    #21596
    Zludlowzludlow
    Member

    I see that now. Will you help me understand why I need to purchase a new license of VC? I thought that came with the template.

    #21604
    Zludlowzludlow
    Member

    I deleted the old version, and attempted to upload the new. I am getting this error:

    Attachments:
    #21607
    Zludlowzludlow
    Member

    Wow. NOT deleting. Assuming that is why I cannot upload the new version.

    Attachments:
    #21643
    VeenaVeena
    Moderator

    Pls try to add the newer version using FTP .

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.