Installation Error

This topic is: not resolved

Tagged: ,

This topic contains 9 replies, has 3 voices, and was last updated by Raghavendra Raghavendra 4 years, 10 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #8083
    Emaish
    emaish
    Member
    Post count: 4

    Dear Support Team,

    each time i try to activate the template i got this error message,

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator to inform of the time the error occurred and of anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Web Server at graffitidesigns.us

    #8084
    Emaish
    emaish
    Member
    Post count: 4
    This reply has been marked as private.
    #8085
    Raghavendra
    Raghavendra
    Moderator
    Post count: 4607

    I am not sure what could be the issue since we have not had anyone report this so far for our theme. Pls check the error log for the server and report back to us if you see anything that we can help with. Thanks.

    #8143
    Emaish
    emaish
    Member
    Post count: 4
    This reply has been marked as private.
    #8144
    Raghavendra
    Raghavendra
    Moderator
    Post count: 4607

    Looks like this could help –

    http://stackoverflow.com/questions/1846882/open-basedir-restriction-in-effect-file-is-not-within-the-allowed-paths

    It is best to have the hosting support solve this issue for you. Only they would have access to some of the php config files that need to be edited.

    #8168
    Emaish
    emaish
    Member
    Post count: 4
    This reply has been marked as private.
    #8170
    Emaish
    emaish
    Member
    Post count: 4

    Dear,

    I solved the issue temporarily by disabling the open_basedir but this is shouldn’t be permenant it’s a security issue, I did so because I couldn’t determine the valid path to include, i tried the following but didn’t work

    Changed it from
    {WEBSPACEROOT}{/}{:}{TMP}{/}{:}
    to
    {WEBSPACEROOT}{/}{:}{TMP}{/}{:}{WEBSPACEROOT}/httpdocs/wp-content/themes/austin/framework/option-tree\languages\theme-mode\

    Can you correct that for me, and by the way the file doesn’t exist in the mentioned path ?!

    Thank you.

    #8171
    Raghavendra
    Raghavendra
    Moderator
    Post count: 4607
    This reply has been marked as private.
    #9817
    Alkoiko
    alkoiko
    Member
    Post count: 1

    Hi,

    I’m tried to install the theme Austin but I have a problem. I need load the austin-sample-data.xml but the plugging Import WordPress is not compatible with PHP 5.5 and I received this errors:

    Strict Standards: Redefining already defined constructor for class WXR_Parser_Regex in /homepages/23/d360385965/htdocs/vertigo/wp/wp-content/plugins/wordpress-importer/parsers.php on line 408

    Strict Standards: Declaration of WP_Import::bump_request_timeout() should be compatible with WP_Importer::bump_request_timeout($val) in /homepages/23/d360385965/htdocs/vertigo/wp/wp-content/plugins/wordpress-importer/wordpress-importer.php on line 38

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/23/d360385965/htdocs/vertigo/wp/wp-content/plugins/wordpress-importer/parsers.php:408) in /homepages/23/d360385965/htdocs/vertigo/wp/wp-includes/option.php on line 750

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/23/d360385965/htdocs/vertigo/wp/wp-content/plugins/wordpress-importer/parsers.php:408) in /homepages/23/d360385965/htdocs/vertigo/wp/wp-includes/option.php on line 751
    Fatal error: Out of memory (allocated 34865152) (tried to allocate 213 bytes) in /homepages/23/d360385965/htdocs/vertigo/wp/wp-content/plugins/wordpress-importer/parsers.php on line 491

    I change the plugin Import WordPress for this https://core.trac.wordpress.org/ticket/24373:
    Replying to unleashyourgeekinc:
    Download /trunk directly via http://downloads.wordpress.org/plugin/wordpress-importer.zip and upload (remember to deactivate and remove your current importer plugin) and see if that works. Per @nacin above this is fixed in trunk but just hasn’t been tagged for release.
    But continuous appear: Fatal error: Out of memory (allocated 34865152) (tried to allocate 213 bytes) in /homepages/23/d360385965/htdocs/vertigo/wp/wp-content/plugins/wordpress-importer/parsers.php on line 491
    I have increasing the memory but not fix my problem. This is my data:

    Usage Sample: 23.08MB (9%)
    Peak Usage: 23.52MB (9%)
    All-Time: 54.45MB on 10/14/14 @ 10:48 am (shutdown)
    Load Averages: 5.99 4.85 4.97
    WP Memory Limit: 96M
    PHP Memory Limit: 120M
    System Overview | Hide…
    PHP Version: 5.5.16
    Server Software: Apache
    User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0

    Opción de configuración PHP 5.5
    allow_call_time_pass_reference No compatible
    allow_url_fopen Activado
    display_errors Activado
    error_reporting 22517
    html_errors Activado
    include_path .:/usr/lib/php5.5
    log_errors Desactivado
    magic_quotes_runtime No compatible
    magic_quotes_sybase No compatible
    max_execution_time 50000
    memory_limit 120M
    post_max_size 8M
    precision 14
    safe_mode Desactivado
    short_open_tag Activado
    upload_max_filesize 40M
    zend framework v2.5.0

    Thanks!

    #9839
    Raghavendra
    Raghavendra
    Moderator
    Post count: 4607

    We cannot much about WordPress importer warnings – other than set WP_DEBUG to false in wp-config.php so that these errors do not show up. Regarding out of memory error, can you increase the memory to a larger value and see if the error goes away. Also, pls open a separate thread for this so that you can track this better.

    Also insert the following into top of functions.php file

    set_time_limit(0);
    ini_set('memory_limit', '20000M');
    

    and see if the error goes away.

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.