Format and Rounding

This topic is: resolved

Tagged: ,

This topic contains 3 replies, has 2 voices, and was last updated by Raghavendra Raghavendra 1 year, 4 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #29179
    Quint Rahaman
    Quint Rahaman
    Participant
    Post count: 5

    Hello,

    It would appear that for the Piecharts module, the values are being rounded improperly. For example, 37.939 rounds down to 37. How can I change that?

    Also, I would like to change the format of the value displayed. For example, the source data as percent driving how long the arc is, is fine. However, the value shown is what I would like to change to the absolute value rather than the percentage. How can this be done?

    Thank you!

    #29185
    Raghavendra
    Raghavendra
    Moderator
    Post count: 4582

    I have done the fix to round the number right. I will release the update tomorrow.

    Regarding the format, I am thinking probably I should just make it an option in the piechart module to allow user to specify a symbol of her/his choice (will perhaps account for the language/locale). While % would be default, the user can make it blank so that no such symbol is displayed. If that works for you, we can make the required change and roll out with the update. Do let us know.

    Of course, for your requirement, you can just use a Custom CSS –

    .labb-piechart .labb-percentage sup {
        display: none;
    }
    #29194
    Quint Rahaman
    Quint Rahaman
    Participant
    Post count: 5

    Thank you for responding and making the edits. I will test tomorrow and report back. As mentioned, it would be a nice feature to drive the arc using the percentage and have the choice of showing the percentage value or the absolute value.

    #29205
    Raghavendra
    Raghavendra
    Moderator
    Post count: 4582

    Have released an update with the fix and an option to set the percent symbol or remove the same. Pls check. Thanks.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.