Enigmatic translation to spanish

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #9415
    Jaygmjaygm
    Member

    Hi,

    I’m having problems while translating enigmatic theme with WPML.

    Here are the problems that I have:

    1) The language selector does not get properly centered in the main manu.
    2) The translated Portfolio does not show all my items, it shows only six but in the spanish version I have 11 (all of them are translated).
    3) Portfolio strings such as client, project date, project datails… do not appear in strings so I can’t translate then.

    I would appreciate your help on these issues. I may go to WMPL support but I have used the plugin in many other themes without having this problems so I guess this is a thems’s problem.

    The website is this. If you want me to provide you with admin details just give me an email and I will send you credentials.

    Thanks for your help in advance.

    #9439
    Jaygmjaygm
    Member

    Ok I fixed the problem number 3, but I still have the other two problems. Please help..

    #9470
    NexusNexus
    Moderator

    Can you pls share the login credentials for your site and I will take a look. Thanks!

    #9482
    Jaygmjaygm
    Member
    This reply has been marked as private.
    #9506
    NexusNexus
    Moderator

    Your site is not loading even after many tries. Can you pls check once? Thanks!

    #9507
    NexusNexus
    Moderator

    I logged in to your site and disabled the ajax for portfolio just to see the url for the next portfolio page and it seems that WPML is appending the lang=en query string to the page before the theme appends the page-2 to the url.

    So the url generated by wpml is
    http://www.masaveuaparcamientos.com/car-parks-masaveu-aparcamientos/?lang=en/page/2/

    which should actually be

    http://www.masaveuaparcamientos.com/car-parks-masaveu-aparcamientos/page/2/?lang=en

    Can you pls contact WPML guys regarding this and find out is there any other WPML settings other than tinkering the url itself to make the page multilingual. I hope it is just a matter of changing a simple setting in WPML.

    Hope that helps. Thanks!

    #9509
    Jaygmjaygm
    Member

    Sorry that is not the URL, This is the one I’m talking about:
    http://www.masaveuaparcamientos.com/parkings-masaveu-aparcamientos/
    http://www.masaveuaparcamientos.com/car-parks-masaveu-aparcamientos/?lang=en

    If you look at the first one you will see that all of the items in the portfolio are in one page… I don’t understand why I’m not getting all the items in one page also for the english portfolio. In fact, if you look at the 1st page of the english version you will see that it says: NO MORE ITEMS TO LOAD. I think this is an error generated by your theme

    #9512
    Jaygmjaygm
    Member

    Moreover, there isn’t a link saying “page 2” or “next page”. This means it is not a matter of WPML is a matter of your theme.

    #9560
    RaghavendraRaghavendra
    Moderator

    I have disabled ajax on the portfolio so that you can see what I am talking about. Now do you see the link to the next portfolio page? See the url and you will find that, WPML is mangling the next page url and adding ?lang=en before the theme adds /page/2 to the url.

    If you can contact WPML guys, they will give a solution to this problem, as this is just a matter of some setting. Thanks!

    #9563
    Jaygmjaygm
    Member

    In wpml have asked me for your contact info. Can you provide this to me? Thanks

    #9565
    RaghavendraRaghavendra
    Moderator
    This reply has been marked as private.
    #9613
    Jaygmjaygm
    Member

    Did they contact you?

    #9614
    RaghavendraRaghavendra
    Moderator

    Nope – so far no.

    #9630
    Jaygmjaygm
    Member
    This reply has been marked as private.
    #9675
    Jaygmjaygm
    Member

    Ok. I got this solved. Thanks

    • This reply was modified 6 years, 10 months ago by Jaygmjaygm.
Viewing 15 posts - 1 through 15 (of 16 total)
  • The topic ‘Enigmatic translation to spanish’ is closed to new replies.