Bug with Polylang (Need to be solved by Theme Dev)

Support Forums for LiveMesh Themes & Plugins Forums Appdev Theme Support Bug with Polylang (Need to be solved by Theme Dev)

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #11187
    Xsaintzxxsaintzx
    Member

    Hi,

    My site URL: http://token-international.com/
    I’m using Polylang for multiple language in my site:
    https://wordpress.org/plugins/polylang/

    Now there’s a small bug with this theme while using Polylang,
    I’m using English as my main site language and Chinese as secondary.
    I’ve created two top menus, one is default English and another is Chinese, with an extra “-cn” for the permalinks of the pages.

    The problem is, if you switch to Chinese in Home page, the menu is still linking to the English menus.

    It seems like the Chinese homepage did not get itself into the “Chinese top menu” I’ve associated with it. Only homepage didn’t work though.

    So I’ve contacted the Polylang developer, it seems the problem lies within the theme, and he asked me to show you this so you can fix it in the theme to make it works correctly, thanks!

    http://polylang.wordpress.com/2014/04/10/incorrect-usage-of-wp_nav_menu/

    #11191
    RaghavendraRaghavendra
    Moderator

    I checked the theme and everywhere we do specify the theme_location parameter. Pls check the files menu-footer.php, menu-primary.php and menu-mobile.php file and everywhere we do have the theme_location parameter specified. Can you check back with them on this please? Thanks

    #11195
    Xsaintzxxsaintzx
    Member

    Hi,

    I’ve revert to the plugin dev, after a test, it seems like that is an incorrect usage about wp_nav_menu in the theme.

    In Appearance > Menus > Manage location tab: Assign your english menu.
    Check if you can display your english menu. Do the same with chinese menu.

    The menu won’t display the Chinese menu.

    Or in general terms, if you create a new menu set and assign it to the top menu bar, it won’t display it.

    #11223
    VeenaVeena
    Moderator

    Pls share temporary login credentials as a private reply.

    #11225
    Xsaintzxxsaintzx
    Member
    This reply has been marked as private.
    #11233
    VeenaVeena
    Moderator

    The given login information is not working.Kindly recheck it and share.

    #11235
    Xsaintzxxsaintzx
    Member
    This reply has been marked as private.
    #11241
    RaghavendraRaghavendra
    Moderator

    Seems to be working now. Able to see two different menus for different language pages as per the setting in Appearance->Menus->Manage Locations.

    The issue earlier was that we had a custom menu “One Page” selected in the page edit window under “Custom Primary Menu” option for the home pages. Choosing the menu there will override what you select under Appearance->Menus->Manage Locations window. Pls ensure that we have “WP Default or Auto” selected for a page for this to work right.

    #11244
    Xsaintzxxsaintzx
    Member
    This reply has been marked as private.
    #11250
    Xsaintzxxsaintzx
    Member

    Realized you deactivated all other plugins and didn’t activate it back, well at least inform me next time.
    Thanks.

    #11252
    VeenaVeena
    Moderator

    we are extremely sorry for the inconvenience caused to you.

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.